Get in touch
Back
Resolved

ZoiAdmin Update

Completed 21 Apr at 11:00pm MST.

zoiadmin.com
Completed

Maintenance ended

Posted 21 Apr at 11:00pm MST.
Started

Zoi will be performing an update on the Zoi Admin Online Console during a 30 minute window. No interruption of service is anticipated.

Posted 21 Apr at 10:30pm MST.