Get in touch
Back
Resolved

Email Reports & Notices

Started 22 Jan at 05:24pm MST.

zoiadmin.com
Created

We are aware of an issue reported by our domain provider with degradation in resolving some email domains that utilize Microsoft O365 that may lead to delays in receiving emailed reports and other other notices. We apologize for any inconvenience.

Posted 22 Jan at 05:24pm MST.