Get in touch
Back
Maintenance

Zoi Admin Hotfix

Completed 13 May at 10:47pm MST.

zoiadmin.com
Completed

Maintenance completed

Posted 13 May at 10:47pm MST.
Started

Zoi Admin will undergo a hotfix update to the server side application which will last for approximately 15 minutes during a 1 hour maintenance window.

Posted 13 May at 10:00pm MST.