Get in touch
Back
Maintenance

Certificate Authority Update

Completed 28 Aug at 12:15am MST.

zoiadmin.com
Completed

Maintenance completed

Posted 28 Aug at 12:15am MST.
Started

Zoi will underdo a certificate authority upgrade on Wednesday August 28th at 12:00am PHX during a 15 minute window. No interruption of service or downtime is predicated.

Posted 28 Aug at 12:00am MST.